KUSANAGI 9モジュール更新情報

KUSANAGI 9モジュール更新情報

KUSANAGI 9 を構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

php 7.3.30-1

モジュールのアップデートについては、以下のコマンドで適用可能です。

# dnf update

phpを使用している場合は以下のコマンドで再起動してください。

# kusanagi php

KUSANAGI 9 バージョンアップ情報 9.0.7-1

KUSANAGI 9 バージョンアップ情報 9.0.7-1

KUSANAGI 9のアップデートを行いました。
デフォルトで/opt/local/binにパスを通すように変更しました。
最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.6-1

KUSANAGI 9 バージョンアップ情報 9.0.6-1

KUSANAGI 9のアップデートを行いました。
データベースにMariaDB 10.6を追加しました。
データベースの指定はkusanagi initコマンドで行います。

# kusanagi init --mariadb10.6

最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.5-1

KUSANAGI 9 バージョンアップ情報 9.0.5-1

KUSANAGI 9のアップデートを行いました。
Python3.9を使用するように変更しました。
アップデートに合わせてkusanagi-pythonがインストールされてpython3コマンドはPython3.9になります。
最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.4-1

KUSANAGI 9 バージョンアップ情報 9.0.4-1

KUSANAGI 9のアップデートを行いました。
MariaDBのログがローテートされていなかった不具合に対応しました。
最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.3-2

KUSANAGI 9 バージョンアップ情報 9.0.3-2

KUSANAGI 9のアップデートを行いました。
kusanagi monit onコマンドが正しく動作していなかった不具合に対応しました。
最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.3-1

KUSANAGI 9 バージョンアップ情報 9.0.3-1

KUSANAGI 9のアップデートを行いました。
nginx 1.21に対応しました。
kusanagi initのデフォルトがnginx 1.21になります。
nginx 1.91は引き続き使用できますが、メンテナンスが行われないためnginx 1.21に移行することを推奨します。
nginx 1.21への移行はkusanagi nginxコマンドで行います。

# kusanagi nginx --use nginx121

最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.2-1

KUSANAGI 9 バージョンアップ情報 9.0.2-1

KUSANAGI 9のアップデートを行いました。
nginx 1.20に対応しました。
kusanagi initコマンドでnginx 1.20が選択できます。

# kusanagi init --nginx120

またkusanagi nginxコマンドでnginx 1.20に変更できます。

# kusanagi nginx --use nginx120

最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.1-3

KUSANAGI 9 バージョンアップ情報 9.0.1-3

KUSANAGI 9のアップデートを行いました。
kusanagi initコマンドでphp80を選択した場合に、php-fpmが起動されない不具合に対応しました。
最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y

KUSANAGI 9 バージョンアップ情報 9.0.1-2

KUSANAGI 9 バージョンアップ情報 9.0.1-2

KUSANAGI 9のアップデートを行いました。
PHP 8.0に対応しました。
kusanagi initコマンドでPHP 8.0が選択できます。

# kusanagi init --php80

またkusanagi phpコマンドでPHP 8.0に変更できます。

# kusanagi php --use php80

最新バージョンへのアップデートについては、以下のコマンドで適用可能です。

# dnf update -y