WEXAL® Page Speed Technology モジュール更新情報

WEXALを構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

kusanagi-prem2.4.2

kusanagi-prem 2.4.2には以下のアップデート内容が含まれます。

改善

  • 戦略生成のために取得してたリソースのうち、WEXALのデータベースに保存するものを以下のとおりに変更しました。
    戦略の精度を維持しつつ、WEXALのデータベースサイズの増加を抑えられます。

    • stylesheetについてはクエリストリングの有無に関わらず拡張子が .css のもののみとしました。
    • scriptについてはクエリストリングの有無に関わらず拡張子が .js のもののみとしました。

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update kusanagi-prem
# cd プロファイルのパス
# pst -v
ProfileのVersionがv2.3.0より前の場合は、pst initに--rebuildconfオプションの指定が必要です。
# pst init --rebuildconf
それ以外の場合
# pst init

リバースプロキシの場合はpst initに--reverseproxyオプション、--originオプションの指定も必要です。

WEXAL® Page Speed Technologyをご利用の方へのお知らせ

kusanagi-prem 2.3.5 より前のバージョンは kusanagi-nginx 1.19.3-1 では動作しません。

kusanagi-nginx 1.19.3-1 へアップデートを行った際にwebサイトが表示されない、表示が乱れるなどの不具合が発生した場合、kusanagi-prem を最新のバージョンにアップデートして下さい。

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update kusanagi-prem
# cd プロファイルのパス
# pst -v
ProfileのVersionがv2.3.0より前の場合は、pst initに--rebuildconfオプションの指定が必要です。
# pst init --rebuildconf
それ以外の場合
# pst init

リバースプロキシの場合はpst initに--reverseproxyオプション、--originオプションの指定も必要です。

KUSANAGIモジュール更新情報

KUSANAGI を構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

nginx1.19.3-1

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update

nginxを使用している場合は、以下のコマンドで再起動してください。

# kusanagi nginx

さらにWEXALを利用している場合は、WEXAL® Page Speed Technologyをご利用の方へのお知らせの手順に従いアップデートを行って下さい。

KUSANAGIモジュール更新情報

KUSANAGI を構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

php7.3.23

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update

WEXAL® Page Speed Technology モジュール更新情報

WEXALを構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

kusanagi-prem2.4.1

kusanagi-prem 2.4.1には以下のアップデート内容が含まれます。

改善

  • ページアクセスのたびにnginxのエラーログに出力されていた不要なメッセージを、出力しないよう変更しました。

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update kusanagi-prem
# cd プロファイルのパス
# pst -v
ProfileのVersionがv2.3.0より前の場合は、pst initに--rebuildconfオプションの指定が必要です。
# pst init --rebuildconf
それ以外の場合
# pst init

リバースプロキシの場合はpst initに--reverseproxyオプション、--originオプションの指定も必要です。

WEXAL® Page Speed Technology モジュール更新情報

WEXALを構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

kusanagi-prem2.4.0

合わせて、以下のモジュールが更新されます。

kusanagi-nodejs-prem1.0.7

kusanagi-prem 2.4.0には以下のアップデート内容が含まれます。

新機能

  • runnerから高速化戦略の生成を行うサービスを分離して、戦略生成が滞っていても最適化コンテンツの生成を継続できるようになりました。
    • 高速化戦略の生成を常にシーケンシャルに処理することで、予期せずサーバ負荷が増加しないようになります。
    • User Agentがクローラーと思われる場合は高速化戦略の生成をスキップして、戦略生成が滞らないようにします。ただし、既に戦略が生成されている場合は、それを適用したコンテンツを返します。
    • 高速化戦略の生成を行うサービスはサーバで共通のものとなります。
    • runnerは引き続きプロファイルごとに最適化コンテンツの生成を行います。

改善

  • WEXAL PST Managerの最適化設定を変更した際、リロードするまで画面に反映されない不具合を修正しました。

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update kusanagi-prem
# cd プロファイルのパス
# pst -v
ProfileのVersionがv2.3.0より前の場合は、pst initに--rebuildconfオプションの指定が必要です。
# pst init --rebuildconf
それ以外の場合
# pst init

リバースプロキシの場合はpst initに--reverseproxyオプション、--originオプションの指定も必要です。

ChromiumアップデートによるWEXAL® Page Speed Technologyの不具合について(2)

ChromiumアップデートによるWEXAL® Page Speed Technologyの不具合についてでお知らせした不具合に対応したモジュールの更新を行いました。

chromium 85.0.4183.83へアップデートしていない場合に、yum updateでchromiumをアップデートしないようにする必要はなくなりました。

WEXAL® Page Speed Technology モジュール更新情報の手順に従いアップデートを行って下さい。

WEXAL® Page Speed Technology モジュール更新情報

WEXALを構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

kusanagi-prem2.3.6

合わせて、以下のモジュールが更新されます。

kusanagi-nodejs-prem1.0.6

kusanagi-prem 2.3.6には以下のアップデート内容が含まれます。

改善

  • chromium 85.0.4183.83へアップデートを行った際に、PSTで戦略が生成されない不具合を修正しました。修正を反映するためには、必ず各プロファイルを2.3.6へ更新してください。

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update kusanagi-prem
# cd プロファイルのパス
# pst -v
ProfileのVersionがv2.3.0より前の場合は、pst initに--rebuildconfオプションの指定が必要です。
# pst init --rebuildconf
それ以外の場合
# pst init

リバースプロキシの場合はpst initに--reverseproxyオプション、--originオプションの指定も必要です。

また、本アップデートで chromium および chromium-common が不要となりました。
他で使用していない場合は、アップデート後に yum erase コマンドで削除可能です。

ChromiumアップデートによるWEXAL® Page Speed Technologyの不具合について

yum updateによりchromium 85.0.4183.83へアップデートを行った際に、PSTで戦略が生成されない不具合が確認されています。

コンテンツの表示には影響はありませんが、PSTによる最適化が行われない場合があります。
直近に作られた戦略が存在すれば、それを適用して表示します。
戦略がない場合はオリジナルのコンテンツを表示します。

画像やCSS、JavaScriptといったリソースの最適化に影響はありません。

  • 対象: 全てのkusanagi-prem
  • 現象: PSTによる新規の戦略生成が行えない

pst ai configコマンドやpst ai screenshotコマンドなどのpst ai ***コマンドも動作しないこと確認しています。

インストールされているchromiumのバージョンは以下のコマンドで確認できます。

# yum list chromium
(中略)
インストール済みパッケージ
chromium.x86_64  85.0.4183.83-1.el7  @epel

chromium 85.0.4183.83へアップデート済の場合、現時点では対処方法がありません。
この不具合に対応したkusanagi-premを準備中です。

chromium 85.0.4183.83へアップデートしていない場合、yum updateでchromiumをアップデートしないようにしてください。
以下のコマンドでアップデートからchromiumのパッケージを除外することができます。

# yum update --exclude='chromium*'

追記)2020年9月23日 19:48
不具合に対応したモジュールの更新を行いました。以下リンクを参照の上アップデートを行って下さい。
WEXAL® Page Speed Technology モジュール更新情報

KUSANAGIモジュール更新情報

KUSANAGI を構成している各モジュールのアップデートを行いました。
アップデートにより適用される各モジュールのバージョンは、以下のとおりとなります。

openssl1.1.1g

モジュールのアップデートについては、以下のコマンドで適用可能です。

# yum update